تهيئة و اعداد

حذف الحسابات المنتهية في نظام الهوتسبوت للمايكروتك Mikrotik Hotspot Delete users automatically

حذف الحسابات المنتهية في نظام الهوتسبوت للمايكروتك

الهوتسبوت في المايكروتك وعناء حذف اليوزرات ( المستخدمين او الكروت )

الحل امر سهل سوف يتم المسح بشكل تلقائي كل ما عليك وضع هذا السكربت مع التعديل المناسب

رول حذف الحسابات منتهية الوقت

{
:local time 2h;
:foreach i in=[/ip hotspot user find where uptime=$time and limit-uptime=$time] do={
:local ahmedalimi [/ip hotspot user remove $i];
}
}

فقط قم بتغيير الـ 2h للوقت الذي حددته لليوزرات ليتم حذف كل الحسابات المنتهية حسب هذا الوقت المستخدم بشكل اتوماتكي .

رول حذف الحسابات منتهية التحميل

{
:local mega 100;
:local byte 1048576;
:local bytes ($byte*$mega);
:foreach i in=[/ip hotspot user find where bytes-out=$bytes and limit-bytes-out=$bytes] do={
:local ahmedalimi [/ip hotspot user remove $i];
}
}

فقط قم بتغيير الـ 100 الى كمية التحميل الذي حددته لليوزرات ليتم حذف كل الحسابات المنتهية حسب هذه القيمة المستخدمة بشكل اتوماتكي .

رول حذف الحسابات منتهية التحميل + الرفع | كمية البيانات الاجمالي limit-bytes-total

{
:local mega 100;
:local byte 1048576;
:local bytes ($byte*$mega);
:foreach i in=[/ip hotspot user find] do={
:local out [/ip hotspot user get $i bytes-out];
:local in [ /ip hotspot user get $i bytes-in];
:local total ($out+$in);
:if ( $total = $bytes ) do={
/ip hotspot user remove $i;
}
}
}

فقط قم بتغيير الـ 100 الى كمية التحميل و الرفع الذي حددته لليوزرات ليتم حذف كل الحسابات المنتهية حسب هذه القيمة المستخدمة بشكل اتوماتكي .

الوسوم

حسين العلي

كاتب و مهتم في المجال التقني محب للمطالعة و دراسة تقانة المعلومات بشكل عام و انا احاول اعادة صياغتها و تقديمها بشكل سهل من المصادر الموثوقة.

اترك تعليقاً

لن يتم نشر عنوان بريدك الإلكتروني. الحقول الإلزامية مشار إليها بـ *

زر الذهاب إلى الأعلى